Not all .pgmx are created, PP Maestro/SCM|Forum|WOOD DESIGNER

Avatar
Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_Feed sp_TopicIcon
Not all .pgmx are created, PP Maestro/SCM
Avatar
Michel

Forum Posts: 998
Subscriber Since:
August 7, 2014
sp_UserOfflineSmall Offline
11
July 6, 2021 - 8:09 pm
sp_Permalink sp_Print

Hi Sandis,

 

This also could be an option as you said that it works fine on one material but goes wrong on another one? Does it go wrong on specific materials? If so maybe some written characters on that material disturb the process to pgmx. There is an option in the PP to avoid this . See below picture

xilog.pngImage Enlarger

Let me know if this helps

 

regards

Michel 

sp_PlupAttachments Attachments
Avatar
Michel

Forum Posts: 998
Subscriber Since:
August 7, 2014
sp_UserOfflineSmall Offline
10
July 6, 2021 - 7:11 pm
sp_Permalink sp_Print sp_EditHistory

Hi Sandis,

 

Sorry for the delay in answering. Here is a document that needed to be translated. Pictures are in french but it should do it. 

This is the reply I got from the developers.

from the simple test we suggested
we may conclude that this issue is very likely due to a wrong tool configuration in Maestro.

Although this setting is not on our side, attached is an internal document (in French) which
might give you some hints about the Maestro tool settings.

If this does not help, then this situation should be directed to SCM because it may happen
that there is an internal link error between XConverter and Maestro (this happened to one
of our Spanish Customers 2 weeks ago, and SCM had to fix it).

I hope this helps. In case you found the solution please let me know. 

 

regards

Michel 

Avatar
jdjoineryltd

Forum Posts: 35
Subscriber Since:
October 30, 2018
sp_UserOfflineSmall Offline
9
June 18, 2021 - 1:01 pm
sp_Permalink sp_Print

Hello Michel!

 

Thanks. Tried all, but without luck.

By manually importing xxl (the ones is missing pgmx) – for some programs there are no errors at all, for some it says that there is no tool present.

Checked tooling file – and tools are there. Not sure which folder PB is looking in for it, but made sure its same file in all places it could look – both Maestro folders and Xilog folder too.

Tried to change tool to something else – results in same problem (with missing new tool), that some xxl`s are ok (ones are missing pgmx) for others i get error when importing them in Maestro – “Tool not present in the selected equipment”. So means that, ones are without errors, still should have created pgmx? How come, that if missing tool for few programs, that it`s there for others?

 

Let me know what else i can try, as need this fixed as soon as possible.

Thanks.

Regards

Sandis

Avatar
Michel

Forum Posts: 998
Subscriber Since:
August 7, 2014
sp_UserOfflineSmall Offline
8
June 17, 2021 - 8:00 pm
sp_Permalink sp_Print

Hi Sandis

 

In order to try to make this long story short, please import manually in Maestro one of the XXL files that are not
converted into a PGMX file.

This should normally generate a message, and give you a clue.

 

regards

Michel 

Avatar
jdjoineryltd

Forum Posts: 35
Subscriber Since:
October 30, 2018
sp_UserOfflineSmall Offline
7
June 17, 2021 - 12:37 pm
sp_Permalink sp_Print

Hi Michel!

Forgot to replay to your questions:

If all XXL files are exported, then you must check: Honestly, I never really bothered to check if all xxl`s are created, as softwares usually work, or they dont.

1- did you change the path for all Post-Processors?Have not changed anything. But have tried to adjust with new Maestro update.
(in case of a Multi Post-Processor)

2- Are all tools properly defined in your toolbox? Yes, all same, nothing have been changed.

 

I can confirm if set converter to WinXiso to create pgm`s , then they all are created and none are missing.

But, WinXiso is not in Maestro folder but in SCM folder – “Xilog Plus”.

XConverter is in Maestro folder, which in newer versions is split in two places. I did try to copy XConverter to other folder where Tlgx, Settings and Cfgx folders are now located, but it was still same outcome – not all pgmx are created.

Avatar
jdjoineryltd

Forum Posts: 35
Subscriber Since:
October 30, 2018
sp_UserOfflineSmall Offline
6
June 17, 2021 - 11:28 am
sp_Permalink sp_Print

Hi Michel!

When i switch to WinXiso – i need to select manually path to it, so when i switch back to XConverter it`s same again – I need to select patch manually as field is empty.

So, that means path to is correct. 

What I don`t understand is – why it creates some pgmx, but not all!?

I have only one PP set up.

 

This is little frustrating, as have jobs where have over 200+ pgmx, and to guess which ones are done, and which ones are not is quite hard.

Regards

Sandis

Avatar
Michel

Forum Posts: 998
Subscriber Since:
August 7, 2014
sp_UserOfflineSmall Offline
5
June 17, 2021 - 11:03 am
sp_Permalink sp_Print

Hi Sandis

 

PolyBoard has not been “re-installed”, but simply “re-downloaded”, which does not lead
to a new path identification.

An alternative to modifying the path in all XXL PPs would be to switch from XConverter
to WiniXiso, validate, then switch back to XConverter and check that the new path has
been selected.

But again, this must be done and checked for all XXL Post-Processors.

 

regards

Michel

Avatar
jdjoineryltd

Forum Posts: 35
Subscriber Since:
October 30, 2018
sp_UserOfflineSmall Offline
4
June 16, 2021 - 3:02 pm
sp_Permalink sp_Print

Ahh, no picture, too large file.

 

Here is google drive link to it – https://drive.google.com/file/…..sp=sharing

Avatar
jdjoineryltd

Forum Posts: 35
Subscriber Since:
October 30, 2018
sp_UserOfflineSmall Offline
3
June 16, 2021 - 3:00 pm
sp_Permalink sp_Print
Hi Michel!

Installed back old version of Maestro, all files are stored in one place and PB creates pgmx correctly.

Reinstalled new version again, re-installed PB (so it can re-check all folder locations as you suggested), and it didn't work at all - no pgmx were created.

Checked again folders:

XConverter is stored in - C:\Program Files (x86)\SCM Group\Maestro.

Cfgx, Settings and Tlgx folders are stored in - C:\Users\Public\Documents\SCM Group\Maestro.

So, after copying Cfgx, Settings and Tlgx folders to C:\Program Files (x86)\SCM Group\Maestro, PB creates pgmx programs, but still partly!

I would want to think it should create all programs or nothing! Don`t understand how it can work partly if something would be missing.

For some materials it creates all pgmx programs, for others some. Attached is pic for example - can see in folder how many are there/missing xxl/pgmx.

Avatar
Michel

Forum Posts: 998
Subscriber Since:
August 7, 2014
sp_UserOfflineSmall Offline
2
June 12, 2021 - 5:55 am
sp_Permalink sp_Print

Hi Sandis

PolyBoard identifies the path to Maestro upon its initial installation,
but it cannot identify further path changes due to updates.

If all XXL files are exported, then you must check:

1- did you change the path for all Post-Processors?
(in case of a Multi Post-Processor)

2- Are all tools properly defined in your toolbox?

 

regards

Michel 

Forum Timezone: Europe/London
Most Users Ever Online: 256
Currently Online:
Guest(s) 15
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Ness: 1939
Tom Cleaver: 162
mark nichols: 160
Conor Devoy: 139
brendan kavanagh: 136
Duayne Naugle: 130
Stu Robertson: 104
Zaheer Abbas: 91
Robert Coxhead: 63
Patrick Maylor: 63
Newest Members:
Jeremy Weber
Qsryche
Sungdo Yusung
Alex test
Gavin Weber
Martin Ahlström
Mario Audisho
mr.jacob.bagoandas@gmail.com
Adam Loiselle
Dov Bolel
Forum Stats:
Groups: 2
Forums: 7
Topics: 2139
Posts: 11662

 

Member Stats:
Guest Posters: 4
Members: 276
Moderators: 0
Admins: 11
Administrators: Stefan, Michel, Carole, Alex, admin, Laly, ipatrick, Crystal, Fatima, Darren, Isaac